Previous Topic

Next Topic

Book Contents

Book Index

Compare Objects

The Compare Objects tool is used to compare the definition of objects. It is mainly used to compare the definition of tables, however it has been configured to compare some other types of objects.

You run the Compare Objects tool from the Database Explorer using the compare icon on the Admin Toolbar. You will see this icon only if the Compare Objects function has been configured for your database and object.

The Compare Objects tool is part of the Extended Edition of AQT, which is a separately purchasable component of AQT. If you have not purchased the Extended Edition you can still use Compare Objects, however you will not be able to use the Compare all objects in schema option. Alternatively you may wish to use the "old" compare tables function that was part of AQT v6.

Using Compare Objects

AQT can compare objects other than tables. The description below explains how Compare Objects works for tables.

Compare

This specifies the objects to be compared.

What to Compare

The What to Compare box shows you all the components that make up the definition of the table. These are:

Select or de-select components to specify what to include in the compare.

Each of these components is defined in AQT as a set of parameters. When you click on one of these components (in the left box) you will be shown these parameters in the Parameter for box:

In general you should not change the Parameter compare settings from the default values.

Save / Open options

File > Save Options will save the details of the components and parameters you have selected to be compared. This can be reloaded with File > Open Options.

Other Options

Report File

AQT can generate a report file that details the differences between the objects. This can be used as a useful summary of the differences.

When viewing the report file in Notepad it is recommended that a non-proportional font (such as Courier New or Fixedsys) is used. The information in the report file is aligned in particular columns, so will display better with these fonts.

You can have <schema> or <table> in your file name. When the compare is run, the schema and object-name of the object being compared are substituted for these. When comparing multiple objects, this allows you to have a different report file for each object.

Note that when you are comparing between different schemas, the Compare schema (eg. the first one specified) is the one substituted in <schema>.

Compare button

This runs the Compare, and shows you the results on the Results tab. To cancel the compare, click on the Abort button (you may neeed to go back to the Options tab to do this).

Viewing the Compare results

These are shown on the Results tab.

This window is divided into three parts, a top grid, and a left and right lower grids:

Top grid

This shows you one row per table compared. For each row, there is a column in the grid showing you how each Component of the table compares. These correspond to the components selected in the What to Compare box in the Options tab.

Left lower grid

Shows details of the item highlighted in the top grid.

In the example of indexes:

Right lower grid